package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s\w+="[^"]*"`)
var str = `<p>
<span
style="color: red"
</span>
</p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}