$re = '~\[mail].*?\[/mail](*SKIP)(*F)|[a-zA-Z0-9_.-]*@\S+\.\w+~i';
$str = '[mail]exmaple@yahoo.com[/mail]
exmaple@yahoo.com';
$subst = "[url=mailto:$0]$0[/url]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;