$re = '/\/\w+\/\w+\/\w+\/(?<your_field>[^\/]+)/m';
$str = 'httpURL: /peerpayment/v1/payment/c611b43d-a574-4636-9116-ec45fe8090f8/performAction';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);