$re = '/(?<!<)<<[^<>]+>>(?!>)/m';
$str = '<<totAmt>>
<<accNum>>
<<agentName>>
<<payLink>>
<<cName>
<<agentName>>>>>>>>
<cName>
<<<<<payLink>>
<<cName<<>>
Hi <<cName>>, please make your payment of $ <<totAmt>> for Account number <<accNum>> given by <<agentName>> at this link <<payLink>>
The validity of this link is 30 minutes. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);