$re = '/\bcat\b/m';
$str = 'The cat scattered his food all over the room.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);