re = /(?<=--> )[a-z ]+(?=\.$)/
str = '<!--/* Font Definitions */@font-face{font-family:Wingdings;panose-1:5 0 0 0 0 0 0 0 0 0;}@font-
face...bottom:0in;}--> pop goes the peanut.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end