$re = '/^([^:\/\/]+):\/\/([\w-.]+)(.*)\/([^\/]+)\?(.*)\/?/m';
$str = 'https://my.domain.com/pluginfile.php/path/path/path/path/document.pdf?token=suker';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);