$re = '/\[[^\]]*hi[^\]]*\|\]/m';
$str = '[he] [picks] [him.|]
[it\'s] [his|] [word.|]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);