use strict;
my $str = '44 .44 444. a
Theses are some of the fail cases that I am looking to
avoid variable123 or variable_123name or _12.3_,
where some of the acceptable cases are |123| or +123+ $123 123% #124523 ext... 11 2123 123% 0.12 1.1.3.4.4x 12 1 23452 23423| ext...[';
my $regex = qr/(?<!\w)\d(?:\.?\d)*(?!\w)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}