import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*/([A-Za-z0-9]{20,})(?:/.*)?$";
final String string = "/v1/api2/5eb98050122d484001708a11f\n\n"
+ "/v1/api1/5eb98050122d484001708a11f/61b3330151e541232146bfb7/\n"
+ "/v1/api1/5eb98050122d484001708a11f/5eb98050122d484001708a11/";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}