#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\d+ \d+ obj(?:(?!\d+ \d+ obj)[\s\S])*?@mail[\s\S]*?endobj"
Local $sString = "12 12 obj" & @CRLF & _
"<<" & @CRLF & _
"Some content here" & @CRLF & _
">>" & @CRLF & _
"endobj" & @CRLF & _
"12 13 obj" & @CRLF & _
"<<" & @CRLF & _
"Some content here with a email address that contains @mail." & @CRLF & _
">>" & @CRLF & _
"endobj" & @CRLF & _
"11 12 obj" & @CRLF & _
"<<" & @CRLF & _
"Some more content here" & @CRLF & _
">>" & @CRLF & _
"endobj" & @CRLF & _
"124 126 obj" & @CRLF & _
"<<" & @CRLF & _
"Some content here" & @CRLF & _
"Another Line too" & @CRLF & _
">>" & @CRLF & _
"endobj" & @CRLF & _
"12 16 obj" & @CRLF & _
"<<" & @CRLF & _
"Some content here" & @CRLF & _
"Another Line" & @CRLF & _
"Another Line" & @CRLF & _
"An @mail address." & @CRLF & _
">>" & @CRLF & _
"endobj"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")