import Foundation
let pattern = #"(.*\-\..*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
filename.jpeg
filename-.png
file name.doc
file name 3.mp4
file name -.dxg
file.name.mov
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)