import re
regex = re.compile(r"RJ.currentMP3Url = \'([\w\\\/-]+)'", flags=re.MULTILINE)
test_str = (" </div>\n"
" </div>\n"
" </div>\n"
" </div>\n"
"</section>\n\n"
"<script>\n"
" \n"
" RJ.currentMP3Url = 'mp3/Arian-Band-To-Ke-Ba-Man-Baashi';\n"
" RJ.currentMP3 = '40008';\n"
" RJ.currentMP3Type = 'mp3';\n"
" RJ.playingIndex = '0';\n"
" RJ.currentMP3Perm = 'Arian-Band-To-Ke-Ba-Man-Baashi';\n\n"
" RJ.currentAlbum = null;\n"
" RJ.currentPlaylist = null;\n\n"
" RJ.relatedMP3 = [{\"next\":\"Arian-Band-To-Ke-Ba-Man-Baashi\",\"index\":0},{\"next\":\"Arian-Band-Bargard\",\"index\":1},{\"next\":\"Arian-Band-Bishtar\",\"index\":2},{\"next\":\"Arian-Band-Deltangiha\",\"index\":3},{\"next\":\"Arian-Band-Faseleh\",\"index\":4},{\"next\":\"Arian-Band-Delam-Barat-Tang-Shodeh\",\"index\":5},{\"next\":\"Arian-Band-To-Moondi-o-Man\",\"index\":6},{\"next\":\"Arian-Band-Nemidoonam\",\"index\":7},{\"next\":\"Arian-Band-Baade-To\",\"index\":8},{\"next\":\"Arian-Band-Too-Cheshaye-Man-Negah-Kon\",\"index\":9},{\"next\":\"Arian-Band-Ta-Abaad\",\"index\":10},{\"next\":\"Arian-Band-Gole-Man\",\"index\":11},{\"next\":\"Arian-Band-Parvaz\",\"index\":12},{\"next\":\"Arian-Band-Gole-Aftab-Gardoon\",\"index\":13},{\"next\":\"Arian-Band-Parvaz-(Club-Mix)\",\"index\":14},{\"next\":\"Arian-Band-Ghasedak\",\"index\":15},{\"next\":\"Arian-Band-Baroon\",\"index\":16},{\"next\":\"Arian-Band-Panjereh\",\"index\":17},{\"next\":\"Arian-Band-Setareh\",\"index\":18},{\"next\":\"Arian-Band-Ey-Javidan-Iran\",\"index\":19},{\"next\":\"Arian-Band-Tab\",\"index\":20},{\"next\":\"Arian-Band-Gole-Hamishe-Bahar\",\"index\":21},{\"next\":\"Arian-Band-Afsoongar\",\"index\":22},{\"next\":\"Arian-Band-Iran\",\"index\":23},{\"next\":\"Arian-Band-The-Words-I-Love-You-(Feat-Chris-de-Burgh)\",\"index\":24},{\"next\":\"Arian-Band-Bi-To-Ba-To\",\"index\":25},{\"next\":\"Arian-Band-Aroom-Aroom\",\"index\":26},{\"next\":\"Arian-Band-Lahzeh-ha\",\"index\":27},{\"next\":\"Arian-Band-Bahooneh\",\"index\":28},{\"next\":\"Arian-Band-Na-Mehraboon\",\"index\":29},{\"next\":\"Arian-Band-Farda-Male-Mast\",\"index\":30}];\n"
" RJ.nextMp3Base = '/mp3s/mp3/';\n"
" RJ.nextMp3AlbumBase = '/mp3s/album/';\n"
" RJ.playerVolume = 75;\n"
" setupMP3Ping();\n"
"</script>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")