$re = '/(?<=testing_filter=)\w{1,}/m';
$str = 'https://test-site.ru/?new=1&testing_filter=old';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);