re = /(?<pair>(?<key>[^&?]+)=(?<value>[^&?]+))+/m
str = 'https://test-site.ru/?new=1&testing_filter=old&name='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end