#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^|\n)[0-9]{4}(-[0-9]{2}){2} ([0-9]{2}:){2}[0-9]{2} LogManager : [^{]*{Name: Hello}\nFetching last name\n{LastName : World"
Local $sString = "2017-11-22 01:43:36 LogManager : Currently processing data {Name: Hello}" & @CRLF & _
"Fetching last name" & @CRLF & _
"{LastName : World}" & @CRLF & _
"2017-11-22 03:12:23 LogManager : Currently processing data {Name: Dummy}" & @CRLF & _
"Fetching last name" & @CRLF & _
"{LastName : Value}" & @CRLF & _
"SomeRandomMessage" & @CRLF & _
"2017-11-22 03:12:23 LogManager : SomeRandomMessage" & @CRLF & _
"Currently processing data {Name: Dummy2}" & @CRLF & _
"Fetching last name" & @CRLF & _
"SomeRandomMessage" & @CRLF & _
"{LastName : Value3}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")