$re = '/((?!www\.)\b\w+\.)?site\.com/m';
$str = 'https://www.prefix.site.com
https://www.site.com
https://prefix.site.com
https://site.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);