$re = '/1(0+)(?=1)/';
$str = '0000010100100010000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);