$re = '/<.*?>/m';
$str = 'Este é um teste de <div>simples div</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);