import Foundation
let pattern = #"[A-Z0-9._%-]+@[A-Z0-9.-]+\.[A-Z]{2,4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Email: regex_cpp@net.br Valid
Email: regex_cpp@terra.com.br Valid
Email: regex_cpp@hotmail.com.br.net Valid (não pode validar)
Email: regex_cpp@hotmail.com Valid
Email: regex_cpp@yahoo.com.br Valid
Email: regex_cpp@gmail.com Valid
Email: regex_cpp@bol.com.br Valid
Email: regex.cpp@bol.com Valid
Email: reg_ex.cpp@bol.com Valid
Email: reg_ex.cpp@org.br Valid
Email: reg_ex.cpp@net.org.br Valid
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)