package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+[²³¹⁰ⁱ⁴⁵⁶⁷⁸⁹⁺⁻⁼⁽⁾ⁿ]+`)
var str = `1¹`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}