using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"host=\K[^;]+";
string input = @"mysql:host=localhost;port=3306;dbname=users";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}