const regex = /iPhone\s+(?<os>\w+)\s+(?<os_version>\w+).*Version\/(?<software_version>[^ ]+)\s+\w+\/\w+\s+(?<software_name>\w+)\/\d+\.\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('iPhone\\s+(?<os>\\w+)\\s+(?<os_version>\\w+).*Version\\\/(?<software_version>[^ ]+)\\s+\\w+\\\/\\w+\\s+(?<software_name>\\w+)\\\/\\d+\\.\\d+$', 'gm')
const str = `Iphone user - Mozilla/5.0 (iPhone; CPU iPhone OS 14_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0 Mobile/15E148 Safari/604.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}