$re = '/(\-[^-.\n]*)(\-.{4})?\.nzb$/m';
$str = 'Movie.Title.2021.1080p.WEB.H264-GRUP-djf3.nzb
Movie.Title.1982.1080p.WEB.H264-GRUP-asJ8.nzb
Movie.Title.2021.1080p.WEB-DL.H264-GRUP-asd8.nzb
Movie.Title.1982.1080p.WEB-DL.H264-GRUP.nzb
Movie.Title.1957.1080p.WEB-DL.DTS-HD.7.1.x264-GRUP.nzb
Movie.Title.2018.1080p.WEB-DL.DTS-HD.5.1.H264-GRUP-asid.nzb
Movie.Title.2021.1080p.WEB-DL.H264-GRUP.nzb
Movie.Title.1982.1080p.WEB-DL.H264-GRUP.nzb
Movie.Title.2021.1080p.WEB-DL.H264-GRUP-kz9j.nzb
Movie.Title.1982.1080p.WEB-DL.H264-GRUP-kk9j.nzb
Movie.Title.1982.1080p.BluRay.DTS-HD.MA.7.1.H264-GRUP.nzb
Movie.Title.1982.1080p.BluRay.DTS-HD.7.1.H264-GRUP.nzb
Movie.Title.2018.1080p.BluRay.DTS-HD.5.1.H264-GRUP.nzb
Movie.Title.1982.1080p.BluRay.DTS-X.7.1.H264-GRUP.nzb
Movie.Title.1982.1080p.BluRay.DTS-X.H264-GRUP.nzb
Movie.Title.1982.1080p.BluRay.DTS-HD.MA.7.1.H264-GRUP-ko9j.nzb
Movie.Title.1982.1080p.BluRay.DTS-HD.7.1.H264-GRUP-kg9j.nzb
Movie.Title.2018.1080p.BluRay.DTS-HD.5.1.H264-GRUP-ko9j.nzb
Movie.Title.1982.1080p.BluRay.DTS-X.7.1.H264-GRUP-zo9j.nzb
Movie.Title.1982.1080p.BluRay.DTS-X.H264-GRUP-k49j.nzb
Movie.Title.1982.1080p.WEB-DL.DTS-HD.MA.7.1.H264-GRUP.nzb
Movie.Title.1982.1080p.WEB-DL.DTS-HD.7.1.H264-GRUP.nzb
Movie.Title.2018.1080p.WEB-DL.DTS-HD.5.1.H264-GRUP.nzb
Movie.Title.1982.1080p.WEB-DL.DTS-X.7.1.H264-GRUP.nzb
Movie.Title.1982.1080p.WEB-DL.DTS-X.H264-GRUP.nzb
Movie.Title.1982.1080p.WEB-DL.DTS-HD.MA.7.1.H264-GRUP-ko4j.nzb
Movie.Title.1982.1080p.WEB-DL.DTS-HD.7.1.H264-GRUP-kiij.nzb
Movie.Title.2018.1080p.WEB-DL.DTS-HD.5.1.H264-GRUP-ko9j.nzb
Movie.Title.1982.1080p.WEB-DL.DTS-X.7.1.H264-GRUP-kd96.nzb
Movie.Title.1982.1080p.WEB-DL.DTS-X.H264-GRUP-koaj.nzb';
$subst = "\1.nzb";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;