re = /^(([^<>()\[\]\.,;:\s@\"]+(\.[^<>()\[\]\.,;:\s@\"]+)*)|(\".+\"))@(([^<>()[\]\.,;:\s@\"]+\.)+[^<>()[\]\.,;:\s@\"]{2,})$/m
str = 'ivanov123@мойсайт.рф'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end