re = /\b\d{1,2}\/\d{1,2}\/\d{4}\s\d{1,2}:\d{2}:\d{2}\s?[AP]M\b/
str = '\\\\SomeServer\\HTTP\\demo1\\index.cfm 4 KB CFM File 2/19/2019 3:48:21 PM 2/19/2019 1:05:53 PM 2/19/2019 1:05:53 PM 5'
# Print the match result
str.match(re) do |match|
puts match.to_s
end