// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(-?(\d*\.)?\d+)((px)|(em)|(%)|(ex)|(ch)|(rem)|(vw)|(vh)|(vmin)|(vmax)|(cm)|(mm)|(in)|(pt)|(pc))$").unwrap();
let string = "23px
3.32423423cm
.87687533mm
34223423em
23423423%
234ex
67ch
4535rem
1vw
435345vh
3.456456vmin
23424234.23423423px
0.3vmax
1pt
435345pc
3.456456in
-23px
-3.32423423cm
-.87687533mm
-34223423em
-23423423%
-234ex
-67ch
-4535rem
-1vw
-435345vh
-3.456456vmin
-23424234.23423423px
-0.3vmax
-1pt
-435345pc
-3.456456in
-1vw
-3.456456vmin";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}