$re = '/^[a-z0-9-]+$/mi';
$str = 'exemplo-de-slug
slug-erradaç
slug-errada 2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);