$re = '/\w/m';
$str = 'palavras pequenas palavras apenas
123123721398721';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);