package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d`)
var str = `palavras pequenas palavras apenas
123123721398721`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}