$re = '/^(?:[^\|]+\|){3}([^\|]+)/';
$str = 'astring| another string|test|maybe some more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);