re = /^(?:[^\|]+\|){0}([^\|]+)/
str = 'astring| another string|test|maybe some more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end