$re = '/\[code\=any\](.+)\[\/code\]/m';
$str = '[code=any]some code inside of here[/code]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);