import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([MTWFS][\\w]{2},) (\\d{2}) ([A-Z][a-z]{2}) (\\d{4}) (\\d{2}:\\d{2}:\\d{2}) ([A-Z]{3,}|[+\\-]\\d+)$";
final String string = "Tue, 04 Jun 2024 04:02:01 GMT\n"
+ "Tue, 04 Jun 2024 04:02:01 +0000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}