$re = '/(?<=is an).*?(?=[.])/m';
$str = 'Palliative care is an approach that improves the quality of life of patients.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);