$re = '/((\d{1,2}h\s?)?(\d{1,2}m\s?)?(\d{1,2}s\s?)?)|\d{1,2}/';
$str = '1h 40m 20s
1h 40m
2h 30s
30m 20s
30m
30 (It will be considered as 30m)
10s
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);