$re = '/^(http(s?):\/\/)?(([a-zA-Z\-_0-9]+)\.)*oupe\.es($|\/.*)/';
$str = 'http://oupe.es/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);