$re = '/^-?[^\d]+$/m';
$str = 't
1
5
y
6
2
8
t';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);