$re = '/[^|]++/m';
$str = '|123|create|item|1497359166334|Football|Some League|\\|Team\\| vs \\|Team\\||1497359216693|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);