import re
regex = re.compile(r"<w-block-content[^>]*>\s*<span[^>]*>\s*<div[^>]*>([^<]*(?:<(?!\/w-block-content)[^<]*)*?)<\/div>\s*<\/span>\s*<\/w-block-content>", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("</tr>\n"
" <td>\n"
" <div draggable=\"true\" class=\"source master draggable-box wysiwyg-block\" data-block-type=\"master\" data-block-id=\"96e80afb-afa0-4e46-bfb7-34b80da76112\" style=\"opacity: 1;\">\n"
" <w-block-content data-block-content-id=\"96e80afb-afa0-4e46-bfb7-34b80da76112\"><span class=\"source-block-tooltip\">\n"
" <div>\n\n"
"Další master<br><div><b>Master č. 2</b> </div><br>\n\n"
" </div>\n"
" </span></w-block-content>\n"
" </div>\n"
" </td>\n"
" </tr>\n"
"</tr>\n"
" <td>\n"
" <div draggable=\"true\" class=\"source master draggable-box wysiwyg-block\" data-block-type=\"master\" data-block-id=\"96e80afb-afa0-4e46-bfb7-34b80da76112\" style=\"opacity: 1;\">\n"
" <w-block-content data-block-content-id=\"96e80afb-afa0-4e46-bfb7-34b80da76112\"><span class=\"source-block-tooltip\">\n"
" <div>\n\n"
"Další master<br><b>Master č. 2</b><br>\n"
" \n"
" </div>\n"
" </span></w-block-content>\n"
" </div>\n"
" </td>\n"
" </tr>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")