re = /(?s)(?:\/\*.*?\*\/|--[^\n]*)/m
str = '/*
SELECT * FROM Table1;
-- Comment in comment
Another SQL code
*/
SQL-code
-- One line comment
/**/ -- Yet one comment
/* And yet one comment */'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end