#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^\/{4}[\r\n]([\s\S]+?(?=^\/{4}[\r\n]))^\/{4}[\r\n]"
Local $sString = "dfdsfsdf" & @CRLF & _
"" & @CRLF & _
"////" & @CRLF & _
"afd" & @CRLF & _
"////" & @CRLF & _
"" & @CRLF & _
"////" & @CRLF & _
"" & @CRLF & _
"/////" & @CRLF & _
"nested" & @CRLF & _
"/////" & @CRLF & _
"" & @CRLF & _
"fdfds" & @CRLF & _
"////" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")