# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w+.jpg"
test_str = ("[{\\\"url\\\":\\\"https:\\\\/\\\\/\\\\/data\\\\/menus\\\\/799\\\\/799\\\\/dd2d49c78b1fe3a9cea5761d90132ff1.jpg\\\",\\\"href\\\":\\\"https:\\\\/\\\\/\\\\/data\\\\/menus\\\\/799\\\\/799\\\\/dd2d49c78b1fe3a9cea5761d90132ff1.jpg\\\",\\\"filename\\\":\\\"dd2d49c78b1fe3a9cea5761d90132ff1.jpg\\\",\\\"url_master\\\":\\\"menus_original\\\\/799\\\\/799\\\\/dd2d49c78b1fe3a9cea5761d90132ff1.jpg\\\",\\\"path_master\\\":\\\"\\\\/home\\\\/foodie\\\\/zomato_data\\\\/menus_original\\\\/799\\\\/799\\\\/dd2d49c78b1fe3a9cea5761d90132ff1.jpg\\\",\\\"data_center\\\":\\\"\\\",\\\"menu_type\\\":\\\"FOOD\\\",\\\"title\\\":\\\"FOOD\\\",\\\"menu_type_class\\\":\\\"FOOD\\\",\\\"real_menu_type\\\":\\\"FOOD\\\",\\\"is_salt_special_menu\\\":0,\\\"start_date\\\":\\\"\\\",\\\"consumer_upload\\\":0,\\\"start_date_formatted\\\":\\\"\\\",\\\"end_date\\\":\\\"\\\",\\\"end_date_formatted\\\":\\\"\\\",\\\"id\\\":131698200},{\\\"url\\\":\\\"https:\\\\/\\\\/\\\\/data\\\\/menus\\\\/799\\\\/799\\\\/f9f923c43b6b2d2a87ad8ce22b9995da.jpg\\\",\\\"href\\\":\\\"https:\\\\/\\\\/\\\\/data\\\\/menus\\\\/799\\\\/799\\\\/f9f923c43b6b2d2a87ad8ce22b9995da.jpg\\\",\\\"filename\\\":\\\"f9f923c43b6b2d2a87ad8ce22b9995da.jpg\\\",\\\"url_master\\\":\\\"menus_original\\\\/799\\\\/799\\\\/f9f923c43b6b2d2a87ad8ce22b9995da.jpg\\\",\\\"path_master\\\":\\\"\\\\/home\\\\/foodie\\\\/zomato_data\\\\/menus_original\\\\/799\\\\/799\\\\/f9f923c43b6b2d2a87ad8ce22b9995da.jpg\\\",\\\"data_center\\\":\\\"\\\",\\\"menu_type\\\":\\\"FOOD\\\",\\\"title\\\":\\\"FOOD\\\",\\\"menu_type_class\\\":\\\"FOOD\\\",\\\"real_menu_type\\\":\\\"FOOD\\\",\\\"is_salt_special_menu\\\":0,\\\"start_date\\\":\\\"\\\",\\\"consumer_upload\\\":0,\\\"start_date_formatted\\\":\\\"\\\",\\\"end_date\\\":\\\"\\\",\\\"end_date_formatted\\\":\\\"\\\",\\\"id\\\":131698203},{\\\"url\\\":\\\"https:\\\\/\\\\/\\\\/data\\\\/menus\\\\/799\\\\/799\\\\/ea3117de65882f14723480841940b5b1.jpg\\\",\\\"href\\\":\\\"https:\\\\/\\\\/\\\\/data\\\\/menus\\\\/799\\\\/799\\\\/ea3117de65882f14723480841940b5b1.jpg\\\",\\\"filename\\\":\\\"ea3117de65882f14723480841940b5b1.jpg\\\",\\\"url_master\\\":\\\"menus_original\\\\/799\\\\/799\\\\/ea3117de65882f14723480841940b5b1.jpg\\\",\\\"path_master\\\":\\\"\\\\/home\\\\/foodie\\\\/zomato_data\\\\/menus_original\\\\/799\\\\/799\\\\/ea3117de65882f14723480841940b5b1.jpg\\\",\\\"data_center\\\":\\\"\\\",\\\"menu_type\\\":\\\"FOOD\\\",\\\"title\\\":\\\"FOOD\\\",\\\"menu_type_class\\\":\\\"FOOD\\\",\\\"real_menu_type\\\":\\\"FOOD\\\",\\\"is_salt_special_menu\\\":0,\\\"start_date\\\":\\\"\\\",\\\"consumer_upload\\\":0,\\\"start_date_formatted\\\":\\\"\\\",\\\"end_date\\\":\\\"\\\",\\\"end_date_formatted\\\":\\\"\\\",\\\"id\\\":131698204}]\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.