import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0*[1-5]?\\d$";
final String string = "12\n"
+ "35\n"
+ "78\n"
+ "8\n"
+ "678\n"
+ "60\n"
+ "80\n"
+ "0\n"
+ "1\n"
+ "04\n"
+ "59\n"
+ "60\n"
+ "0000004";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}