#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-5]*\d$"
Local $sString = "12" & @CRLF & _
"35" & @CRLF & _
"78" & @CRLF & _
"8" & @CRLF & _
"678" & @CRLF & _
"60" & @CRLF & _
"80" & @CRLF & _
"0" & @CRLF & _
"1" & @CRLF & _
"04" & @CRLF & _
"59" & @CRLF & _
"60" & @CRLF & _
"0000004"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")