re = /^(0*|[0-5]?)\d$/m
str = '12
35
78
8
678
60
80
0
1
04
59
60
0000004
5555555
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end