$re = '/^(?:0*|[0-5]?)\d$/m';
$str = '12
35
78
8
678
60
80
0
1
04
59
60
0000004
5555555
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);