const regex = /^\[(?<group>.*)(?<!:children)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[(?<group>.*)(?<!:children)\\]', 'gm')
const str = `[man-aged-sql:children]
ManagedMSSQLDBMS2016DBAMode
ManagedMSSQLServer2016
ManagedMSSQLServer2017
[all_managed:children]
server01
server02
[notmanaged]
server04
server05
[ManagedMSSQLServer2016]
Server4
Server5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}