$re = '/[\d\/]+(?=\srooms?)/m';
$str = '"Apartment at Chennai has 4 rooms with a swimming pool"
"this apartment has 2/3 room with a coridor"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);