using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=notificationDate"": "").+?(?="")";
string input = @"{""notificationBy"": ""37"", ""notificationDate"": ""2018-08-08 16:35""}, ""ref_id";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}